AM ServerFreeware download in progress...

This is the Server for AM Messenger. You need this application in order to use AM Messenger. I is based on activex components. You must upgrade AM Messenger to v1.2.0 as AM Server 1.2.0 is not compatible with older versions.

If your download does not start, click the following link : Download here or visit developer's homepage.

Feel free to browse our freeware site - your download will continue in the background.